logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
ray22901031  
#1 Posted : Thursday, February 13, 2020 3:20:44 PM(UTC)
ray22901031

Rank: Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 27

Strange behavior with the skin.css file.

I can duplicate this on two fresh installs on my end, last night I was working with the skin.css file on my server modifying the:

background-image: url(images/pattern.png);
background-color: #FFFFFF;

Nothing serious, just turning off the background pattern, and playing with a few colors. This morning when I try to do the same thing, the system will not reflect the new changes. I have reset the IIS server, I have turned off caching, I have tried different browsers, I have rebooted all computers, same thing.

When I load the main page either using Firefox or Chrome and hit F12, I am not able to manipulate the settings either, what am I missing here?

Thanks

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

shari  
#2 Posted : Friday, February 14, 2020 4:34:32 AM(UTC)
shari

Rank: Advanced Member

Groups: Admin, Authorized User, Registered, Developers
Joined: 10/5/2018(UTC)
Posts: 42

Was thanked: 7 time(s) in 7 post(s)
Hi,

Please note that skin.css is intended to be used for our CMS theme editing feature from the UI. This file should not be changed from an editor.

To add your custom styles, you need to edit custom.css file under Themes/{Name}/Content/custom.css. These changes will override the default styling.

As far as your case is concerned this is not clear why aren't you seeing the desired results. If you use the UI component to edit the theme standard styles it may become clear to you.
We recommend you to try making similar changes from UI.

  • Please login as admin
  • Visit Home page
  • Turn on the editing mode using the floating menu on the right side of the screen
  • Then slide open the left bar using the arrow
  • Select the THEME tab from the top
  • Select the Background option and try changing the background color/image
  • On the bottom, you will have the option to first see the preview and if the changes are final you can Publish the changes.


Please also note that:
preview changes are reflected using skin.preview.css
published changes are reflected using skin.css

ray22901031  
#3 Posted : Friday, February 14, 2020 10:36:37 AM(UTC)
ray22901031

Rank: Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 27

Hello Shari,

Thank you for your reply, this now makes sense as to why the background image was constantly showing even though it was commented out. I'm assuming the best way for those of us who want to manually edit the skin.css file is just copy the entire thing into the custom.css file.

Would you say this is the recommended approach?

The reason I was not seeing the changes after a manual edit, was that you could not commented out the "background-image: url(images/pattern.png)", it would still show, what was needed to be done was either pick another image or exclusively tell it not to display it by the using "background-image: none;".

Thanks
ray22901031  
#4 Posted : Friday, February 14, 2020 11:00:04 AM(UTC)
ray22901031

Rank: Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 27

Hello Shari,

UPDATE !

Trying to override the background image in the custom.css is not working for me, could you see if it's working for you and if so just post your code for review.

Thanks
ray22901031  
#5 Posted : Friday, February 14, 2020 11:04:01 AM(UTC)
ray22901031

Rank: Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 27

Works if you use the "!important" tag at the end. - Just sharing information.
shari  
#6 Posted : Friday, February 14, 2020 11:44:05 AM(UTC)
shari

Rank: Advanced Member

Groups: Admin, Authorized User, Registered, Developers
Joined: 10/5/2018(UTC)
Posts: 42

Was thanked: 7 time(s) in 7 post(s)
Hi,

Quote:
Would you say this is the recommended approach?


Sure, you can do so if you need to manually change the styles.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.