logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

2 Pages<12
Options
Go to last post Go to first unread
katie_able_support  
#21 Posted : Tuesday, November 17, 2020 12:28:03 PM(UTC)
katie_able_support

Rank: Advanced Member

Groups: Administrators, Developers, Registered, HelpDesk, System
Joined: 10/29/2018(UTC)
Posts: 107

Thanks: 2 times
Was thanked: 10 time(s) in 9 post(s)
Hi,

If you look at your Configure > Email > Settings page, you can check to see the mail account displayed for "Store Email". It's a little easier than querying the database :)

However, from the error message above, it looks like you might need to contact Comcast.

Quote:
Mailbox unavailable. The server response was: 5.1.0 Sender is not allowed to send from comcast.net


Please keep us updated.

Katie
Thanks for your support!
Katie
IDAutomation  
#22 Posted : Tuesday, November 17, 2020 12:38:48 PM(UTC)
IDAutomation

Rank: Member

Groups: Authorized User, Developers
Joined: 11/13/2018(UTC)
Posts: 23

Thanks: 16 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: katie_able_support Go to Quoted Post
Hi,

If you look at your Configure > Email > Settings page, you can check to see the mail account displayed for "Store Email". It's a little easier than querying the database :)

However, from the error message above, it looks like you might need to contact Comcast.

Quote:
Mailbox unavailable. The server response was: 5.1.0 Sender is not allowed to send from comcast.net


Please keep us updated.

Katie


Hi Katie, thanks for writing. The mail account displayed for Store Email is admin@idautomation.com . The error message I provided is one example. I have 8 of them as of now (got one more since posting my last response). All of them have failed. The Contact Us Form initiates an email to send from the customer. The customer in this error log had a comcast email. Each of the error logs I have refer to a different domain, because it is based on the email address of the customer. I cannot contact every domain and ask them why they're not allowing our contact form to send, can I?

From what I gather in the error log, the form is trying to send an email from the domain the user entered in the email field in the form. There has to be something about this form that is preventing the email from sending. We have completely disabled our spam filters for this test and it changed nothing. Our other *@idautomation.com emails are working just fine. admin@idautomation.com is receiving emails in ALL other respects aside from this contact form.

I guess I am at a dead end here, unless you have any other ideas.
jeffr_ca  
#23 Posted : Tuesday, November 17, 2020 12:52:56 PM(UTC)
jeffr_ca

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 1/7/2019(UTC)
Posts: 85

Thanks: 1 times
Hi,

Along the same line that I discovered, is your "Store Email" the same address as your "Email Server Configuration" log-in details (SMTP Username on my configuration)?

If they are different, I had to permit my primary email address in Gmail to "Send From" a different address that we are specifying in the "Store Email" field.

-Jeff
IDAutomation  
#24 Posted : Tuesday, November 17, 2020 12:56:05 PM(UTC)
IDAutomation

Rank: Member

Groups: Authorized User, Developers
Joined: 11/13/2018(UTC)
Posts: 23

Thanks: 16 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: jeffr_ca Go to Quoted Post
Hi,

Along the same line that I discovered, is your "Store Email" the same address as your "Email Server Configuration" log-in details (SMTP Username on my configuration)?

If they are different, I had to permit my primary email address in Gmail to "Send From" a different address that we are specifying in the "Store Email" field.

-Jeff


Hi Jeff, thanks for weighing in. I wish I could tell you they were different, that might solve the problem! Unfortunately my Store Email and the email for my SMTP Username are both the same.
jeffr_ca  
#25 Posted : Tuesday, November 17, 2020 1:34:29 PM(UTC)
jeffr_ca

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 1/7/2019(UTC)
Posts: 85

Thanks: 1 times
Just following back to your note "The Contact Us Form initiates an email to send from the customer..... the form is trying to send an email from the domain the user entered in the email field in the form."

Someone please correct me otherwise, but I don't believe that's how it is working. I can initiate a message on our contact form with a bogus email address and the Contact Message email arrives in my email inbox. It looks to me like the AC store is sending the email from the "Store Email" and just showing the contents of the Contact Form. I don't know that the customer's email address is relevant at all at this stage.

-Jeff

jeffr_ca  
#26 Posted : Tuesday, November 17, 2020 1:54:18 PM(UTC)
jeffr_ca

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 1/7/2019(UTC)
Posts: 85

Thanks: 1 times
You had mentioned an "auto-response" in an earlier message.... I don't think my system sends any sort of confirmation to Contact Us inquiries. Is this something that needs to be switched on?

-Jeff
katie_able_support  
#27 Posted : Tuesday, November 17, 2020 2:51:31 PM(UTC)
katie_able_support

Rank: Advanced Member

Groups: Administrators, Developers, Registered, HelpDesk, System
Joined: 10/29/2018(UTC)
Posts: 107

Thanks: 2 times
Was thanked: 10 time(s) in 9 post(s)
Quote:
I can initiate a message on our contact form with a bogus email address and the Contact Message email arrives in my email inbox


This is working for me as well. We just upgraded to version 9.0.3.
Thanks for your support!
Katie
jeffr_ca  
#28 Posted : Tuesday, November 17, 2020 2:56:34 PM(UTC)
jeffr_ca

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 1/7/2019(UTC)
Posts: 85

Thanks: 1 times
I've just browsed to idautomation.com

Is this the Contact Us form that is being tested? It is non-standard.

-Jeff
IDAutomation  
#29 Posted : Tuesday, November 17, 2020 3:33:16 PM(UTC)
IDAutomation

Rank: Member

Groups: Authorized User, Developers
Joined: 11/13/2018(UTC)
Posts: 23

Thanks: 16 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: jeffr_ca Go to Quoted Post
I've just browsed to idautomation.com

Is this the Contact Us form that is being tested? It is non-standard.

-Jeff


Hi Jeff. We have removed the Contact Form at this point and redirected it to an about us page that contains an email button with a more traditional mailto: reference. That is most likely what you are seeing now. Unfortunately we cannot afford to have these emails just get lost in the void and so we're having to move back to a more dependable method, even if site visitors tend not to use it as much. I'd love to find a solution for this but all roads are leading nowhere at this point, I'm sorry to say.
jeffr_ca  
#30 Posted : Tuesday, November 17, 2020 6:53:42 PM(UTC)
jeffr_ca

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 1/7/2019(UTC)
Posts: 85

Thanks: 1 times
I'm very sorry to see that the problem has become so frustrating. I am optimistic that there will be a proper solution for you as we've been able to confirm that the form works on our test system so far with the adjusted Gmail Server configuration.
Joe Payne @ AbleMods LLC  
#31 Posted : Wednesday, November 18, 2020 7:44:57 AM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 146

Thanks: 33 times
Was thanked: 5 time(s) in 5 post(s)
This issue is caused by how Able populates the email header after the contact-us form is submitted.

When Able populates the header, they are setting the FROM address of the email to be the shopper's email address. Most likely this was done based on the presumption that the merchant could simply click reply to that contact-us email and respond directly to the shopper.

Code:

                mailMessage.From = new System.Net.Mail.MailAddress(model.Email);
                mailMessage.Subject = model.parameters.Subject;
                mailMessage.Body += "Name: " + model.FullName + Environment.NewLine;


However, most major email servers/providers will not permit a FROM address on a new email that does not match the email of the account used to authenticate their email server.

For example, let's say my SMTP server settings are configured to log into my mail server using 'foo@payne.com'. Many mail providers will not allow the store to send an email with the FROM value of anything other than 'foo@payne.com'. Bigger systems such as Comcast, ZOHO and Office365 all have strict requirements such as this to reduce spam.

What Able should be doing is populating the 'ReplyToList' with the shopper email instead of the FROM address. Email clients such as Outlook will use the REPLY-TO value of the email if one was specified when the email was sent. So the end goal of making it easy for merchants to reply to contact-us forms is still achieved.

The FROM address should always be set to match the SMTP username configured in the Able store settings. This is the only way to get many of the major email servers to accept email from an external source such as an Able website. Even then, it can be a challenge. For example, there are additional challenges when trying to use an Office365 account to send emails from an Able store.
jeffr_ca  
#32 Posted : Wednesday, November 18, 2020 9:46:39 AM(UTC)
jeffr_ca

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 1/7/2019(UTC)
Posts: 85

Thanks: 1 times
Thanks Joe,

That all seems to make sense. In our 7.0.3. we had the Store Email as "info@..." but my Server login credentials were "jeff@...." The Contact form had worked for all these years, but contact us emails that arrived always showed From "jeff@..." despite the Store Email being "info@...." I never cared, because it worked.

AC9 appears a bit different because we confirmed that contact emails were failing with the above settings. This thread lead me to check our Gmail configuration and I discovered that Gmail allows you to create a FROM alias that is attached to your primary email address. So, I was able to add "info@...." as a recognized FROM address within my "jeff@...." account.

Since doing that, contact us emails from 7.0.3 now arrive showing the From address of "info@...." That's how it should have worked all the while, but it appears that Gmail permitted the emails to pass through anyway. Luckily now with this configuration change, the contact us emails in AC9 also work.

Interestingly that despite the Gmail configuration anomaly, AC9 transaction emails like order confirmations, customer notes/messages and shipping confirmations, etc. have worked without any problems in AC7 and in AC9. So it would appear the emails sent for store operations are constructed differently than they are for the Contact Form.

Thanks for your time checking this out.

-Jeff
Joe Payne @ AbleMods LLC  
#33 Posted : Wednesday, November 18, 2020 1:02:01 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 146

Thanks: 33 times
Was thanked: 5 time(s) in 5 post(s)
Every email provider is different. And the rules are changing. Some providers that permitted it before, no longer do. Often without any advance warning. So you can literally wake up one day to find none of your store emails will go out.

Some providers offer a workaround. Others simply don't care. Office365 is the WORST to work with, and of course is wildly popular.

Regular store transaction emails are indeed constructed differently in the code.
IDAutomation  
#34 Posted : Thursday, November 19, 2020 8:51:14 AM(UTC)
IDAutomation

Rank: Member

Groups: Authorized User, Developers
Joined: 11/13/2018(UTC)
Posts: 23

Thanks: 16 times
Was thanked: 1 time(s) in 1 post(s)
There was a fix already suggested a couple of months ago and this fixed our problem with the Contact Us form :)

https://www.ablecommerce...e-through-email#post1594
Users browsing this topic
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.