logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
AbleMods Joe Payne  
#1 Posted : Monday, January 7, 2019 10:58:36 AM(UTC)
AbleMods Joe Payne

Rank: Newbie

Groups: Developers, Registered, HelpDesk
Joined: 11/7/2018(UTC)
Posts: 7

I'm unable to install b4510 in my hosting environment. The SQL scripts blow up badly. It looks like certain SQL script commands are hard-coded to the dbo schema.

For example, ac_Layouts never gets populated properly because some of the SQL inserts are hardcoded to the dbo schema. Here is example text copied from the install page 1:

Quote:

INSERT [dbo].[ac_Layouts] ([LayoutId], [DisplayName], [Description], [FilePath], [IsGenerated], [LayoutTypeId]) VALUES (10, N'Store Header Menubar', N'Layout for Store Header Menubar board', N'~/Views/Shared/Boards/StoreHeaderMenubar.cshtml', 0, 2)


This happens in several other tables too. The install is unusable after the scripts finish.

Suggestions?

Joe Payne, AbleMods LLC
www.ablemods.com
www.ablemodshosting.com

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

MikeR  
#2 Posted : Monday, February 4, 2019 1:38:13 PM(UTC)
MikeR

Rank: Advanced Member

Groups: Administrators, Developers, Registered, HelpDesk, System, Admin
Joined: 10/18/2018(UTC)
Posts: 116

Was thanked: 5 time(s) in 5 post(s)
Hello Joe,

I'm not sure how to replicate this issue and we've never run into it. How are you setting up your database, which results in them not being prefixed by dbo?

Thanks!
Mike
Thank you for your support!
Mike Randolph
AbleCommerce.com
katie_able_support  
#3 Posted : Tuesday, February 5, 2019 8:20:22 AM(UTC)
katie_able_support

Rank: Advanced Member

Groups: Developers, Registered, HelpDesk, System
Joined: 10/29/2018(UTC)
Posts: 72

Was thanked: 2 time(s) in 2 post(s)
Hi Joe,

The SQL scripts are fixed now. I can send them over if you like.

Thanks
Katie
judy at Web2Market  
#4 Posted : Thursday, February 7, 2019 5:22:19 AM(UTC)
judy at Web2Market

Rank: Advanced Member

Groups: HelpDesk, Developers
Joined: 11/7/2018(UTC)
Posts: 58

Was thanked: 1 time(s) in 1 post(s)
Thanks for fixing that. In the past, I have occasionally run across a site where the tables were not dbo so it would have been a problem with them.
AbleMods Joe Payne  
#5 Posted : Tuesday, February 19, 2019 9:42:44 AM(UTC)
AbleMods Joe Payne

Rank: Newbie

Groups: Developers, Registered, HelpDesk
Joined: 11/7/2018(UTC)
Posts: 7

Katie was this fixed in B4895? I'm still seeing [dbo] issue on my systems with B4895.
Joe Payne, AbleMods LLC
www.ablemods.com
www.ablemodshosting.com
katie_able_support  
#6 Posted : Tuesday, February 19, 2019 11:17:47 AM(UTC)
katie_able_support

Rank: Advanced Member

Groups: Developers, Registered, HelpDesk, System
Joined: 10/29/2018(UTC)
Posts: 72

Was thanked: 2 time(s) in 2 post(s)
Hi Joe,

Sorry, but this wasn't totally fixed until recently (after RC1). I am going to send you the new SQL scripts. Place them in the \Website\Areas\Install\Content\ folder and then you should be good to go.


Thanks!

Katie
Joe Payne @ AbleMods LLC  
#7 Posted : Thursday, February 21, 2019 1:36:04 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Member

Groups: Developers
Joined: 11/9/2018(UTC)
Posts: 18

Hi Katie any progress on sending me updated install scripts?
katie_able_support  
#8 Posted : Thursday, February 21, 2019 2:37:09 PM(UTC)
katie_able_support

Rank: Advanced Member

Groups: Developers, Registered, HelpDesk, System
Joined: 10/29/2018(UTC)
Posts: 72

Was thanked: 2 time(s) in 2 post(s)
Hi Joe,

I sent them on Tuesday, and again just a few minutes ago. Please check and see if you have them.

Thanks
Katie
Joe Payne @ AbleMods LLC  
#9 Posted : Thursday, February 21, 2019 2:39:15 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Member

Groups: Developers
Joined: 11/9/2018(UTC)
Posts: 18

Just got them both, thanks.
Joe Payne @ AbleMods LLC  
#10 Posted : Thursday, February 21, 2019 2:47:04 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Member

Groups: Developers
Joined: 11/9/2018(UTC)
Posts: 18

That worked perfectly, thank you
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.