logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to AbleCommerce Gold forum. Please use your AbleCommerce username and password to Login. New Registrations are disabled.

Notification

Icon
Error

Options
Go to last post Go to first unread
gdelorey2939345  
#1 Posted : Wednesday, January 11, 2023 5:04:16 PM(UTC)
gdelorey2939345

Rank: Newbie

Groups: Authorized User, Developers
Joined: 11/2/2021(UTC)
Posts: 8

Hi AC -

We received the following notice from Braintree regarding the .NET SDK for our 9.0.6 site:

==
Action needed: Update your Braintree .NET SDK.

Our records show that you may be using an old version of the Braintree .NET SDK.

A new version of the SDK was released on November 1, 2022, with new security enhancements. Please upgrade to the Braintree Python SDK v.5.14.0 or higher as soon as possible. Starting February 28, 2023, older versions of the SDK may no longer be supported.

To make this update:
If you're currently using v5 of the .NET SDK, you need to upgrade the SDK to v5.14.0 or higher. Your integration will not require any other changes.
If you're currently using v4 or lower of the Braintree .NET SDK, please upgrade to the recently released .NET v4.18.1. Your integration will not require any other changes.
If you're currently using v3 or lower of the Braintree .NET SDK, please upgrade to the recently released .NET v4.18.1 and refer to the migration guide to make any integration changes.
Should this remediation require an update to your integration, you may need to engage a developer or speak to your shopping cart or third-party provider.

For any questions, don’t hesitate to contact Braintree Support for assistance.
==

Is AC aware of these upcoming changes and/or are there any updates available for this payment gateway?

Thanks,
Greg

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. New Registrations are disabled.

shaharyar  
#2 Posted : Thursday, January 12, 2023 12:09:47 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 666

Thanks: 5 times
Was thanked: 112 time(s) in 111 post(s)
Hi Greg,

Thank you for pointing this out.
We will try to consider this for our next release.

Regards
jdepoy24549696  
#3 Posted : Monday, January 23, 2023 4:35:19 PM(UTC)
jdepoy24549696

Rank: Advanced Member

Groups: Authorized User, Developers, Registered
Joined: 4/17/2019(UTC)
Posts: 78

We need more info on this.
I have a client running AC 9.0.2 and using Braintree exclusively for payments.
Will their integration still work after Feb. 28?
shaharyar  
#4 Posted : Monday, January 23, 2023 11:35:05 PM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 666

Thanks: 5 times
Was thanked: 112 time(s) in 111 post(s)
Hi,

They have shared a few details on their website. https://developer.paypal...r-sdk-deprecation-policy

Please read the info given on the page.

In 9.0.2, the version was 2.64.0!
Currently, the latest version of AC9 is 9.0.7 and it is using Braintree v5.6.
We will be upgrading the Braintree to the latest in the upcoming release.

So it is recommended to update to the latest AC9 version. Moreover, you can also contact Braintree Support for assistance.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.