logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
SteveFeher  
#1 Posted : Wednesday, May 8, 2019 10:39:09 AM(UTC)
SteveFeher

Rank: Newbie

Groups: HelpDesk, Developers
Joined: 11/1/2018(UTC)
Posts: 6

I'm building out a new site in AC version 9 RC3, and the new method of creating pages --- with their naming conventions, etc. -- is all good.

However, I've changed some things and now find that I'm caught in an odd loop of redirects. When I visit the admin section of
Website > Configure > SEO > Fixed Redirects
I cannot DELETE any of the older (now irrelevant) redirects.

1.) I click on the redirect record that I want to eliminate
2.) The onscreen warning asks to validate the deletion (am I sure that I want to delete). I say yes.
3.) The onscreen confirmation appears that the deletion was successful, but the redirect remains in place. No changes were actually made.


Anyone else see this happening?

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

ray22901031  
#2 Posted : Thursday, May 9, 2019 12:13:04 AM(UTC)
ray22901031

Rank: Newbie

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 3

This brings back nightmares of when I had to deal with Magento 2.

Yes, I have noticed this, however you're building a new site, so unless the search engines have already crawled the site, you don't need redirects at this point, at least that is my interpretation. If I go to the product itself, and I make sure that I instigate some type of change to the URL and save it, hit preview, it works for me so far 100% of the time.

I then go and delete the redirects for that product, since I don't have any hard coding that points to this individual product. I've also tried going to the product using the built-in drop-down menu after instigating a URL change, and it finds the product with the new URL all the time, at least so far.

Try making the change let's say in Firefox using the backend, and then open Chrome and try to search for your product, could it be a caching issue maybe with the browser?

Magento was a nightmare when it came to redirects, tens of thousands of entries were automatically created for even the slightest change.

I hope some of this helps, but love to hear what AbleCommerce says.

-Ray
SteveFeher  
#3 Posted : Wednesday, May 15, 2019 9:31:03 PM(UTC)
SteveFeher

Rank: Newbie

Groups: HelpDesk, Developers
Joined: 11/1/2018(UTC)
Posts: 6

Ultimately the resolution was this:

The homepage CANNOT be named anything other than https://www.yourdomain.com/default
For those of us who sometimes change the default page in a folder to something else (Index, home, whatever) and simply change the setting in IIS, you cannot do this now.

Your default homepage must always remain named "Default"

HTH
Steve
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.